hplip: needs dynamic library
[buildroot-gz.git] / package / libshout / libshout.mk
blob029c134412f15bfceb5827112889b3b419880a8b
1 ################################################################################
3 # libshout
5 ################################################################################
7 LIBSHOUT_VERSION = 2.4.1
8 LIBSHOUT_SITE = http://downloads.xiph.org/releases/libshout
9 LIBSHOUT_LICENSE = LGPLv2+
10 LIBSHOUT_LICENSE_FILES = COPYING
11 LIBSHOUT_INSTALL_STAGING = YES
12 LIBSHOUT_DEPENDENCIES = host-pkgconf libogg libvorbis
14 ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
15 LIBSHOUT_CONF_OPTS += --enable-theora
16 LIBSHOUT_DEPENDENCIES += libtheora
17 else
18 LIBSHOUT_CONF_OPTS += --disable-theora
19 endif
21 ifeq ($(BR2_PACKAGE_SPEEX),y)
22 LIBSHOUT_CONF_OPTS += --enable-speex
23 LIBSHOUT_DEPENDENCIES += speex
24 else
25 LIBSHOUT_CONF_OPTS += --disable-speex
26 endif
28 $(eval $(autotools-package))