hplip: needs dynamic library
[buildroot-gz.git] / package / poppler / poppler.mk
blobc6cd2eb92fb8f99c768dbf41ddb6499d71889f72
1 ################################################################################
3 # poppler
5 ################################################################################
7 POPPLER_VERSION = 0.32.0
8 POPPLER_SOURCE = poppler-$(POPPLER_VERSION).tar.xz
9 POPPLER_SITE = http://poppler.freedesktop.org
10 POPPLER_DEPENDENCIES = fontconfig host-pkgconf
11 POPPLER_LICENSE = GPLv2+
12 POPPLER_LICENSE_FILES = COPYING
13 POPPLER_INSTALL_STAGING = YES
14 POPPLER_CONF_OPTS = --with-font-configuration=fontconfig \
15 --enable-xpdf-headers
17 ifeq ($(BR2_PACKAGE_LCMS2),y)
18 POPPLER_CONF_OPTS += --enable-cms=lcms2
19 POPPLER_DEPENDENCIES += lcms2
20 else
21 POPPLER_CONF_OPTS += --enable-cms=none
22 endif
24 ifeq ($(BR2_PACKAGE_TIFF),y)
25 POPPLER_CONF_OPTS += --enable-libtiff
26 # Help poppler to find libtiff in static linking scenarios
27 POPPLER_CONF_ENV += \
28 LIBTIFF_LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libtiff-4`"
29 POPPLER_DEPENDENCIES += tiff
30 else
31 POPPLER_CONF_OPTS += --disable-libtiff
32 endif
34 ifeq ($(BR2_PACKAGE_JPEG),y)
35 POPPLER_CONF_OPTS += --enable-libjpeg
36 POPPLER_DEPENDENCIES += jpeg
37 else
38 POPPLER_CONF_OPTS += --disable-libjpeg
39 endif
41 ifeq ($(BR2_PACKAGE_LIBPNG),y)
42 POPPLER_CONF_OPTS += --enable-libpng
43 POPPLER_DEPENDENCIES += libpng
44 else
45 POPPLER_CONF_OPTS += --disable-libpng
46 endif
48 ifeq ($(BR2_PACKAGE_ZLIB),y)
49 POPPLER_CONF_OPTS += --enable-zlib
50 POPPLER_DEPENDENCIES += zlib
51 else
52 POPPLER_CONF_OPTS += --disable-zlib
53 endif
55 ifeq ($(BR2_PACKAGE_POPPLER_LIBCURL),y)
56 POPPLER_CONF_OPTS += --enable-libcurl
57 POPPLER_DEPENDENCIES += libcurl
58 else
59 POPPLER_CONF_OPTS += --disable-libcurl
60 endif
62 ifeq ($(BR2_PACKAGE_XORG7),y)
63 POPPLER_CONF_OPTS += --with-x
64 POPPLER_DEPENDENCIES += xlib_libX11 xlib_libXext
65 else
66 POPPLER_CONF_OPTS += --without-x
67 endif
69 ifeq ($(BR2_PACKAGE_POPPLER_QT),y)
70 POPPLER_DEPENDENCIES += qt
71 POPPLER_CONF_OPTS += --enable-poppler-qt4
72 else
73 POPPLER_CONF_OPTS += --disable-poppler-qt4
74 endif
76 ifeq ($(BR2_PACKAGE_OPENJPEG),y)
77 POPPLER_DEPENDENCIES += openjpeg
78 POPPLER_CONF_OPTS += --enable-libopenjpeg
79 else
80 POPPLER_CONF_OPTS += --enable-libopenjpeg=none
81 endif
83 $(eval $(autotools-package))