package/nbd: add option for the trdump utility
[buildroot-gz.git] / package / pinentry / pinentry.mk
blobbcb910a0e2ef9fd38826bbe2392c3388ef1b8285
1 ################################################################################
3 # pinentry
5 ################################################################################
7 PINENTRY_VERSION = 0.9.4
8 PINENTRY_SOURCE = pinentry-$(PINENTRY_VERSION).tar.bz2
9 PINENTRY_SITE = ftp://ftp.gnupg.org/gcrypt/pinentry
10 PINENTRY_LICENSE = GPLv2+
11 PINENTRY_LICENSE_FILES = COPYING
12 PINENTRY_DEPENDENCIES = \
13 $(if $(BR2_PACKAGE_LIBICONV),libiconv) \
14 host-pkgconf
15 PINENTRY_CONF_OPTS += --without-libcap # requires PAM
17 # pinentry uses some std::string functionality that needs C++11
18 # support when gcc >= 5.x. This should be removed when bumping
19 # pinentry, since newer versions no longer use std::string.
20 ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_5),y)
21 PINENTRY_CONF_ENV = CXXFLAGS="$(TARGET_CXXFLAGS) -std=gnu++11"
22 endif
24 # build with X if available
25 ifeq ($(BR2_PACKAGE_XORG7),y)
26 PINENTRY_CONF_OPTS += --with-x
27 else
28 PINENTRY_CONF_OPTS += --without-x
29 endif
31 ifeq ($(BR2_PACKAGE_LIBSECRET),y)
32 PINENTRY_CONF_OPTS += --enable-libsecret
33 PINENTRY_DEPENDENCIES += libsecret
34 else
35 PINENTRY_CONF_OPTS += --disable-libsecret
36 endif
38 # pinentry-ncurses backend
39 ifeq ($(BR2_PACKAGE_PINENTRY_NCURSES),y)
40 PINENTRY_CONF_OPTS += --enable-ncurses --with-ncurses-include-dir=none
41 PINENTRY_DEPENDENCIES += ncurses
42 else
43 PINENTRY_CONF_OPTS += --disable-ncurses
44 endif
46 # pinentry-gtk2 backend
47 ifeq ($(BR2_PACKAGE_PINENTRY_GTK2),y)
48 PINENTRY_CONF_OPTS += --enable-pinentry-gtk2
49 PINENTRY_DEPENDENCIES += libgtk2
50 else
51 PINENTRY_CONF_OPTS += --disable-pinentry-gtk2
52 endif
54 # pinentry-qt4 backend
55 ifeq ($(BR2_PACKAGE_PINENTRY_QT4),y)
56 # -pthread needs to be passed for certain toolchains
57 # http://autobuild.buildroot.net/results/6be/6be109ccedec603a67cebdb31b55865dcce0e128/
58 PINENTRY_CONF_OPTS += LIBS=-pthread MOC=$(HOST_DIR)/usr/bin/moc
59 PINENTRY_CONF_OPTS += --enable-pinentry-qt4
60 PINENTRY_DEPENDENCIES += qt
61 else
62 PINENTRY_CONF_OPTS += --disable-pinentry-qt4
63 endif
65 $(eval $(autotools-package))