package/nbd: add option for the trdump utility
[buildroot-gz.git] / package / sdl2_gfx / sdl2_gfx.mk
blob975bca73adf0c76040ae7b04922fbb7e0e92ce0d
1 ################################################################################
3 # sdl2_gfx
5 ################################################################################
7 SDL2_GFX_VERSION = 1.0.1
8 SDL2_GFX_SOURCE = SDL2_gfx-$(SDL2_GFX_VERSION).tar.gz
9 SDL2_GFX_SITE = http://www.ferzkopp.net/Software/SDL2_gfx
10 SDL2_GFX_LICENSE = zlib
11 SDL2_GFX_LICENSE_FILES = COPYING SDL2_framerate.h
12 SDL2_GFX_INSTALL_STAGING = YES
13 SDL2_GFX_DEPENDENCIES = sdl2 host-pkgconf
14 SDL2_GFX_CONF_OPTS = --disable-sdltest
15 # configure/Makefile.in not up-to-date, causing aclocal to be used at
16 # build time if we don't autoreconf.
17 SDL2_GFX_AUTORECONF = YES
19 # Even though x86_64 processors support MMX, the MMX-specific assembly
20 # code in sdl2_gfx is IA32 specific, and does not build for x86_64.
21 ifeq ($(BR2_i386)$(BR2_X86_CPU_HAS_MMX),yy)
22 SDL2_GFX_CONF_OPTS += --enable-mmx
23 else
24 SDL2_GFX_CONF_OPTS += --disable-mmx
25 endif
27 $(eval $(autotools-package))