1 ################################################################################
5 ################################################################################
7 XINETD_VERSION
= xinetd-2-3-15
8 XINETD_SITE
= $(call github
,xinetd-org
,xinetd
,$(XINETD_VERSION
))
9 XINETD_LICENSE
= xinetd license
10 XINETD_LICENSE_FILES
= COPYRIGHT
12 XINETD_CFLAGS
= $(TARGET_CFLAGS
)
15 # 1. We have libtirpc, use it by passing special flags
16 # 2. We have native RPC support, use it, no need to pass special
17 # flags (so this case 2 is implicit and not visible below)
18 # 3. We don't have RPC support, pass -DNO_RPC to disable it
19 ifeq ($(BR2_PACKAGE_LIBTIRPC
),y
)
20 XINETD_DEPENDENCIES
+= libtirpc host-pkgconf
21 XINETD_CFLAGS
+= "`$(PKG_CONFIG_HOST_BINARY) --cflags libtirpc`"
22 XINETD_LIBS
+= "`$(PKG_CONFIG_HOST_BINARY) --libs libtirpc`"
23 else ifeq ($(BR2_TOOLCHAIN_HAS_NATIVE_RPC
),)
24 XINETD_CFLAGS
+= -DNO_RPC
28 CFLAGS
="$(XINETD_CFLAGS)" \
31 XINETD_MAKE_OPTS
= AR
="$(TARGET_AR)"
33 $(eval
$(autotools-package
))