Remove BR2_DEPRECATED
[buildroot-gz.git] / package / putty / putty.mk
blobca86c47052366dd9073260e7cd46cd9b35b24cdf
1 ################################################################################
3 # putty
5 ################################################################################
7 PUTTY_VERSION = 0.67
8 PUTTY_SOURCE = putty-$(PUTTY_VERSION).tar.gz
9 PUTTY_SITE = http://the.earth.li/~sgtatham/putty/$(PUTTY_VERSION)
10 PUTTY_SUBDIR = unix
11 PUTTY_LICENSE = MIT
12 PUTTY_LICENSE_FILES = LICENCE
13 PUTTY_CONF_OPTS = --disable-gtktest
15 ifeq ($(BR2_PACKAGE_LIBGTK2),y)
16 PUTTY_CONF_OPTS += --with-gtk=2
17 PUTTY_DEPENDENCIES += libgtk2
18 else
19 PUTTY_CONF_OPTS += --without-gtk
20 endif
22 $(eval $(autotools-package))