website: update Free Electrons logo
[buildroot-gz.git] / package / gnuplot / gnuplot.mk
bloba9e12045ec78e9daccf37e11a4c9a9da19e1e7ba
1 ################################################################################
3 # gnuplot
5 ################################################################################
7 GNUPLOT_VERSION = 4.6.6
8 GNUPLOT_SITE = http://downloads.sourceforge.net/project/gnuplot/gnuplot/$(GNUPLOT_VERSION)
9 GNUPLOT_LICENSE = gnuplot license (open source)
10 GNUPLOT_LICENSE_FILES = Copyright
12 GNUPLOT_AUTORECONF = YES
14 GNUPLOT_CONF_OPTS = \
15 --without-x \
16 --disable-raise-console \
17 --disable-mouse \
18 --without-tutorial \
19 --disable-demo \
20 --without-row-help \
21 --disable-history-file \
22 --without-lisp-files \
23 --disable-wxwidgets \
24 --without-lua \
25 --without-latex \
26 --without-cairo
28 # relocation truncated to fit: R_68K_GOT16O
29 ifeq ($(BR2_m68k_cf),y)
30 GNUPLOT_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mxgot"
31 endif
33 ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
34 GNUPLOT_CONF_OPTS += --with-gd
35 GNUPLOT_DEPENDENCIES += gd
36 GNUPLOT_CONF_ENV += \
37 ac_cv_path_GDLIB_CONFIG=$(STAGING_DIR)/usr/bin/gdlib-config
38 else
39 GNUPLOT_CONF_OPTS += --without-gd
40 endif
42 ifeq ($(BR2_PACKAGE_READLINE),y)
43 GNUPLOT_CONF_OPTS += --with-readline=gnu
44 GNUPLOT_DEPENDENCIES += readline
45 else
46 GNUPLOT_CONF_OPTS += --without-readline
47 endif
49 # Remove Javascript scripts, lua scripts, PostScript files
50 define GNUPLOT_REMOVE_UNNEEDED_FILES
51 $(RM) -rf $(TARGET_DIR)/usr/share/gnuplot
52 endef
54 GNUPLOT_POST_INSTALL_TARGET_HOOKS += GNUPLOT_REMOVE_UNNEEDED_FILES
56 $(eval $(autotools-package))