package/rpcbind: fix musl build
[buildroot-gz.git] / package / alljoyn-tcl / alljoyn-tcl.mk
bloba5c7e4ec837537374cb8da5f05ebc7f5d38eed2c
1 ################################################################################
3 # alljoyn-tcl
5 ################################################################################
7 ALLJOYN_TCL_REV = 16.04
8 ALLJOYN_TCL_VERSION = $(ALLJOYN_TCL_REV).00
9 ALLJOYN_TCL_SOURCE = ajtcl-$(ALLJOYN_TCL_VERSION)-src.tar.gz
10 ALLJOYN_TCL_SITE = \
11 https://mirrors.kernel.org/allseenalliance/alljoyn/$(ALLJOYN_TCL_REV)
12 # See https://allseenalliance.org/alliance/ip-policy
13 ALLJOYN_TCL_LICENSE = ISC
15 ALLJOYN_TCL_DEPENDENCIES = host-scons
16 ALLJOYN_TCL_INSTALL_STAGING = YES
18 # AllJoyn Thin Core can be compiled in debug or release mode. By default,
19 # AllJoyn Thin Core is built in debug mode.
20 ALLJOYN_TCL_VARIANT = release
22 ALLJOYN_TCL_SCONS_OPTS = \
23 -j$(PARALLEL_JOBS) \
24 V=1 \
25 VARIANT=$(ALLJOYN_TCL_VARIANT) \
26 CC="$(TARGET_CC)" \
27 CXX="$(TARGET_CXX)"
29 define ALLJOYN_TCL_BUILD_CMDS
30 cd $(@D); $(SCONS) $(ALLJOYN_TCL_SCONS_OPTS)
31 endef
33 define ALLJOYN_TCL_INSTALL_STAGING_CMDS
34 cp -a $(@D)/dist/lib/lib* $(STAGING_DIR)/usr/lib/
35 cp -a $(@D)/dist/include/* $(STAGING_DIR)/usr/include/
36 endef
38 # Only install AllJoyn Thin Core dynamic libraries into target directory
39 define ALLJOYN_TCL_INSTALL_TARGET_CMDS
40 cp -a $(@D)/dist/lib/lib*.so* $(TARGET_DIR)/usr/lib/
41 endef
43 $(eval $(generic-package))