1 ################################################################################
5 ################################################################################
8 LIBVPX_SOURCE
= libvpx-
$(LIBVPX_VERSION
).
tar.bz2
9 LIBVPX_SITE
= http
://storage.googleapis.com
/downloads.webmproject.org
/releases
/webm
10 LIBVPX_LICENSE
= BSD-3c
11 LIBVPX_LICENSE_FILES
= LICENSE PATENTS
12 LIBVPX_INSTALL_STAGING
= YES
14 # ld is being used with cc options. therefore, pretend ld is cc.
17 CROSS
=$(GNU_TARGET_NAME
)
24 # This is not a true autotools package. It is based on the ffmpeg build system
25 define LIBVPX_CONFIGURE_CMDS
26 (cd
$(LIBVPX_SRCDIR
) && rm -rf config.cache
&& \
27 $(TARGET_CONFIGURE_OPTS
) \
28 $(TARGET_CONFIGURE_ARGS
) \
31 --target
=generic-gnu \
34 $(SHARED_STATIC_LIBS_OPTS
) \
39 define LIBVPX_BUILD_CMDS
40 $(TARGET_MAKE_ENV
) $(LIBVPX_MAKE_ENV
) $(MAKE
) -C
$(@D
) all
43 define LIBVPX_INSTALL_STAGING_CMDS
44 $(TARGET_MAKE_ENV
) $(LIBVPX_MAKE_ENV
) $(MAKE
) DESTDIR
="$(STAGING_DIR)" -C
$(@D
) install
47 define LIBVPX_INSTALL_TARGET_CMDS
48 $(TARGET_MAKE_ENV
) $(LIBVPX_MAKE_ENV
) $(MAKE
) DESTDIR
="$(TARGET_DIR)" -C
$(@D
) install
51 $(eval
$(generic-package
))