package/rpcbind: fix musl build
[buildroot-gz.git] / package / libvpx / libvpx.mk
blob4ad552249841cd2e402a96924dad4badefe3f2e9
1 ################################################################################
3 # libvpx
5 ################################################################################
7 LIBVPX_VERSION = 1.6.0
8 LIBVPX_SOURCE = libvpx-$(LIBVPX_VERSION).tar.bz2
9 LIBVPX_SITE = http://storage.googleapis.com/downloads.webmproject.org/releases/webm
10 LIBVPX_LICENSE = BSD-3c
11 LIBVPX_LICENSE_FILES = LICENSE PATENTS
12 LIBVPX_INSTALL_STAGING = YES
14 # ld is being used with cc options. therefore, pretend ld is cc.
15 LIBVPX_CONF_ENV = \
16 LD="$(TARGET_CC)" \
17 CROSS=$(GNU_TARGET_NAME)
19 LIBVPX_CONF_OPTS = \
20 --disable-examples \
21 --disable-docs \
22 --disable-unit-tests
24 # This is not a true autotools package. It is based on the ffmpeg build system
25 define LIBVPX_CONFIGURE_CMDS
26 (cd $(LIBVPX_SRCDIR) && rm -rf config.cache && \
27 $(TARGET_CONFIGURE_OPTS) \
28 $(TARGET_CONFIGURE_ARGS) \
29 $(LIBVPX_CONF_ENV) \
30 ./configure \
31 --target=generic-gnu \
32 --enable-pic \
33 --prefix=/usr \
34 $(SHARED_STATIC_LIBS_OPTS) \
35 $(LIBVPX_CONF_OPTS) \
37 endef
39 define LIBVPX_BUILD_CMDS
40 $(TARGET_MAKE_ENV) $(LIBVPX_MAKE_ENV) $(MAKE) -C $(@D) all
41 endef
43 define LIBVPX_INSTALL_STAGING_CMDS
44 $(TARGET_MAKE_ENV) $(LIBVPX_MAKE_ENV) $(MAKE) DESTDIR="$(STAGING_DIR)" -C $(@D) install
45 endef
47 define LIBVPX_INSTALL_TARGET_CMDS
48 $(TARGET_MAKE_ENV) $(LIBVPX_MAKE_ENV) $(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
49 endef
51 $(eval $(generic-package))