1 ################################################################################
5 ################################################################################
8 GLOG_SITE
= $(call github
,google
,glog
,$(GLOG_VERSION
))
9 GLOG_INSTALL_STAGING
= YES
11 GLOG_LICENSE_FILES
= COPYING
13 ifeq ($(BR2_PACKAGE_GFLAGS
),y
)
14 GLOG_DEPENDENCIES
= gflags
17 # glog can optionally use atomic __sync built-ins. However, its
18 # configure script only checks for the availability of the 4 bytes
19 # version, but the code also uses the 1 byte version. While this works
20 # on most architectures, it does not on architectures that implement
21 # only the 4 bytes version, such as Microblaze. So if the architecture
22 # does not implement the 1 byte version, we hint the configure script
23 # that atomic built-ins should not be used.
24 ifeq ($(BR2_TOOLCHAIN_HAS_SYNC_1
),)
25 GLOG_CONF_ENV
+= ac_cv___sync_val_compare_and_swap
=no
28 $(eval
$(autotools-package
))