sysklogd: fix build on musl
[buildroot-gz.git] / package / usbredir / usbredir.mk
blob6765a9baac6bd06bdb48d1dd10cccb1afc71dccf
1 ################################################################################
3 # usbredir
5 ################################################################################
7 USBREDIR_VERSION = 0.7.1
8 USBREDIR_SOURCE = usbredir-$(USBREDIR_VERSION).tar.bz2
9 USBREDIR_SITE = http://spice-space.org/download/usbredir
10 USBREDIR_LICENSE = LGPLv2.1+ (libraries)
11 USBREDIR_LICENSE_FILES = COPYING.LIB
12 USBREDIR_INSTALL_STAGING = YES
13 USBREDIR_DEPENDENCIES = host-pkgconf libusb
15 ifeq ($(BR2_PACKAGE_USBREDIR_SERVER),y)
17 USBREDIR_LICENSE := $(USBREDIR_LICENSE), GPLv2+ (program)
18 USBREDIR_LICENSE_FILES += COPYING
20 else # BR2_PACKAGE_USBREDIR_SERVER != y
22 define USBREDIR_POST_INSTALL_TARGET_RM_SERVER
23 rm -f $(TARGET_DIR)/usr/sbin/usbredirserver
24 endef
25 USBREDIR_POST_INSTALL_TARGET_HOOKS += USBREDIR_POST_INSTALL_TARGET_RM_SERVER
27 endif # BR2_PACKAGE_USBREDIR_SERVER
29 $(eval $(autotools-package))