odroid-mali: new package
[buildroot-gz.git] / package / celt051 / celt051.mk
blob9e2578187302dd2662b929ff6e525021ccaedae1
1 ################################################################################
3 # celt
5 ################################################################################
7 # Although version newer than 0.5.1.3 exists, we're
8 # stuck with 0.5.1.3 for use by Spice (coming later)
9 CELT051_VERSION = 0.5.1.3
10 CELT051_SOURCE = celt-$(CELT051_VERSION).tar.gz
11 CELT051_SITE = http://downloads.xiph.org/releases/celt
12 CELT051_LICENSE = BSD-2c
13 CELT051_LICENSE_FILES = COPYING
14 CELT051_INSTALL_STAGING = YES
15 CELT051_DEPENDENCIES = libogg
17 # Need to specify --with-ogg, otherwise /usr/lib may be searched for
18 # if target is the same kind as host (ie. same arch, same bitness,
19 # same endianness, so that /usr/lib contains libraries linkable by
20 # our cross-compiler)
21 CELT051_CONF_OPTS = \
22 --enable-fixed-point \
23 --disable-fixed-point-debug \
24 --disable-experimental-postfilter \
25 --disable-static-modes \
26 --disable-assertions \
27 --disable-oggtest \
28 --with-ogg=$(STAGING_DIR)/usr \
30 $(eval $(autotools-package))