1 ################################################################################
5 ################################################################################
8 RANGER_SITE
= http
://ranger.nongnu.org
9 RANGER_SETUP_TYPE
= distutils
10 RANGER_LICENSE
= GPLv3
11 RANGER_LICENSE_FILES
= AUTHORS
13 # The ranger script request python to be called with -O (optimize generated
14 # bytecode slightly; also PYTHONOPTIMIZE=x). This implicitly requires the python
15 # source files to be present. Therefore, the -O flag is removed when only the .pyc
16 # files are installed.
18 define RANGER_DO_NOT_GENERATE_BYTECODE_AT_RUNTIME
19 $(SED
) 's%/usr/bin/python -O%/usr/bin/python%g' $(@D
)/scripts
/ranger
22 ifeq ($(BR2_PACKAGE_PYTHON3_PYC_ONLY
)$(BR2_PACKAGE_PYTHON_PYC_ONLY
),y
)
23 RANGER_POST_PATCH_HOOKS
+= RANGER_DO_NOT_GENERATE_BYTECODE_AT_RUNTIME
26 $(eval
$(python-package
))