1 ################################################################################
5 ################################################################################
7 SHELLINABOX_VERSION
= v2.19
8 SHELLINABOX_SITE
= $(call github
,shellinabox
,shellinabox
,$(SHELLINABOX_VERSION
))
9 SHELLINABOX_LICENSE
= GPLv2 with OpenSSL exception
10 SHELLINABOX_LICENSE_FILES
= COPYING GPL-2
12 # Fetching from Github, and patching Makefile.am, so we need to autoreconf
13 SHELLINABOX_AUTORECONF
= YES
15 # The OpenSSL support is supposed to be optional, but in practice,
16 # with OpenSSL disabled, it fails to build. See
17 # https://github.com/shellinabox/shellinabox/issues/385.
18 SHELLINABOX_DEPENDENCIES
= zlib openssl
19 SHELLINABOX_CONF_OPTS
= \
20 --disable-runtime-loading \
23 $(eval
$(autotools-package
))