1 ################################################################################
5 ################################################################################
8 ACL_SOURCE
= acl-
$(ACL_VERSION
).src.
tar.gz
9 ACL_SITE
= http
://download.savannah.gnu.org
/releases
/acl
10 ACL_INSTALL_STAGING
= YES
11 ACL_DEPENDENCIES
= attr
12 ACL_CONF_OPTS
= --enable-gettext
=no
13 ACL_LICENSE
= GPLv2
+ (programs
), LGPLv2.1
+ (libraries
)
14 ACL_LICENSE_FILES
= doc
/COPYING doc
/COPYING.LGPL
16 # While the configuration system uses autoconf, the Makefiles are
17 # hand-written and do not use automake. Therefore, we have to hack
18 # around their deficiencies by passing installation paths.
19 ACL_INSTALL_STAGING_OPTS
= \
20 prefix=$(STAGING_DIR
)/usr \
21 exec_prefix=$(STAGING_DIR
)/usr \
22 PKG_DEVLIB_DIR
=$(STAGING_DIR
)/usr
/lib \
23 install-dev install-lib
25 ACL_INSTALL_TARGET_OPTS
= \
26 prefix=$(TARGET_DIR
)/usr \
27 exec_prefix=$(TARGET_DIR
)/usr \
30 # The libdir variable in libacl.la is empty, so let's fix it. This is
31 # probably due to acl not using automake, and not doing fully the
32 # right thing with libtool.
33 define ACL_FIX_LIBTOOL_LA_LIBDIR
34 $(SED
) "s,libdir=.*,libdir='$(STAGING_DIR)'," \
35 $(STAGING_DIR
)/usr
/lib
/libacl.la
38 ACL_POST_INSTALL_STAGING_HOOKS
+= ACL_FIX_LIBTOOL_LA_LIBDIR
40 $(eval
$(autotools-package
))