toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / ibrdtnd / ibrdtnd.mk
blob01ebb7ab36f4f84d0bb0d6078bd510a7bf6fd4fa
1 ################################################################################
3 # ibrdtnd
5 ################################################################################
7 IBRDTND_VERSION = 1.0.1
8 IBRDTND_SOURCE = ibrdtnd-$(IBRDTND_VERSION).tar.gz
9 IBRDTND_SITE = https://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
10 IBRDTND_LICENSE = Apache-2.0
11 IBRDTND_LICENSE_FILES = COPYING
12 IBRDTND_DEPENDENCIES = ibrdtn ibrcommon host-pkgconf
14 # Disable features that don't have the necessary dependencies in
15 # Buildroot
16 IBRDTND_CONF_OPTS = \
17 --disable-dtndht \
18 --without-wifip2p \
19 --without-vmime
21 # don't build documentation
22 IBRDTND_CONF_ENV = PDFLATEX='no'
24 ifeq ($(BR2_PACKAGE_LIBDAEMON),y)
25 IBRDTND_CONF_OPTS += --enable-libdaemon
26 IBRDTND_DEPENDENCIES += libdaemon
27 else
28 IBRDTND_CONF_OPTS += --disable-libdaemon
29 endif
31 ifeq ($(BR2_PACKAGE_LIBCURL),y)
32 IBRDTND_CONF_OPTS += --with-curl
33 IBRDTND_DEPENDENCIES += libcurl
34 else
35 IBRDTND_CONF_OPTS += --without-curl
36 endif
38 ifeq ($(BR2_PACKAGE_SQLITE),y)
39 IBRDTND_CONF_OPTS += --with-sqlite
40 IBRDTND_DEPENDENCIES += sqlite
41 else
42 IBRDTND_CONF_OPTS += --without-sqlite
43 endif
45 ifeq ($(BR2_PACKAGE_OPENSSL),y)
46 IBRDTND_CONF_OPTS += --with-tls
47 IBRDTND_DEPENDENCIES += openssl
48 else
49 IBRDTND_CONF_OPTS += --without-tls
50 endif
52 $(eval $(autotools-package))