toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / iozone / iozone.mk
blob477a60a3bb2407d8eba376aee5bf5a971e48f8b8
1 ################################################################################
3 # iozone
5 ################################################################################
7 IOZONE_VERSION = 3_446
8 IOZONE_SOURCE = iozone$(IOZONE_VERSION).tar
9 IOZONE_SITE = http://www.iozone.org/src/current
10 IOZONE_LICENSE = IOzone license (NO DERIVED WORKS ALLOWED)
11 # IOzone license details can be found at:
12 # http://www.iozone.org/docs/Iozone_License.txt
14 # AIO support not available on uClibc, use the linux (non-aio) target.
15 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
16 IOZONE_TARGET = linux-noaio
17 else
18 IOZONE_TARGET = linux
19 endif
21 define IOZONE_BUILD_CMDS
22 $(MAKE) $(TARGET_CONFIGURE_OPTS) $(IOZONE_TARGET) -C $(@D)/src/current
23 endef
25 define IOZONE_INSTALL_TARGET_CMDS
26 $(INSTALL) -D -m 755 $(@D)/src/current/iozone \
27 $(TARGET_DIR)/usr/bin/iozone
28 endef
30 $(eval $(generic-package))