toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / lcms2 / lcms2.mk
blob8d0609ea1e12686a83cc16c0d894097ebadffa33
1 ################################################################################
3 # lcms2
5 ################################################################################
7 LCMS2_VERSION = 2.8
8 LCMS2_SITE = http://downloads.sourceforge.net/project/lcms/lcms/$(LCMS2_VERSION)
9 LCMS2_LICENSE = MIT
10 LCMS2_LICENSE_FILES = COPYING
11 LCMS2_INSTALL_STAGING = YES
13 LCMS2_CONF_OPTS = \
15 ifeq ($(BR2_PACKAGE_JPEG),y)
16 LCMS2_CONF_OPTS += --with-jpeg
17 LCMS2_DEPENDENCIES += jpeg
18 else
19 LCMS2_CONF_OPTS += --without-jpeg
20 endif
22 ifeq ($(BR2_PACKAGE_TIFF),y)
23 LCMS2_CONF_OPTS += --with-tiff
24 LCMS2_DEPENDENCIES += tiff
25 else
26 LCMS2_CONF_OPTS += --without-tiff
27 endif
29 ifeq ($(BR2_PACKAGE_ZLIB),y)
30 LCMS2_CONF_OPTS += --with-zlib
31 LCMS2_DEPENDENCIES += zlib
32 else
33 LCMS2_CONF_OPTS += --without-zlib
34 endif
36 $(eval $(autotools-package))