toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / lxc / lxc.mk
blobe9e925f4403d1997c11ac62051a1885a004a4b05
1 ################################################################################
3 # lxc
5 ################################################################################
7 LXC_VERSION = 2.0.6
8 LXC_SITE = https://linuxcontainers.org/downloads/lxc
9 LXC_LICENSE = LGPLv2.1+
10 LXC_LICENSE_FILES = COPYING
11 LXC_DEPENDENCIES = libcap host-pkgconf
12 LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
13 --disable-python --disable-werror \
14 $(if $(BR2_PACKAGE_BASH),,--disable-bash)
16 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
17 LXC_CONF_OPTS += --enable-seccomp
18 LXC_DEPENDENCIES += libseccomp
19 else
20 LXC_CONF_OPTS += --disable-seccomp
21 endif
23 ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER),y)
24 LXC_CONF_OPTS += --enable-lua
25 LXC_DEPENDENCIES += luainterpreter
26 ifeq ($(BR2_PACKAGE_LUAJIT),y)
27 # By default, lxc will only search for lua.pc
28 LXC_CONF_OPTS += --with-lua-pc=luajit
29 endif
30 else
31 LXC_CONF_OPTS += --disable-lua
32 endif
34 $(eval $(autotools-package))