1 ################################################################################
5 ################################################################################
8 LXC_SITE
= https
://linuxcontainers.org
/downloads
/lxc
9 LXC_LICENSE
= LGPLv2.1
+
10 LXC_LICENSE_FILES
= COPYING
11 LXC_DEPENDENCIES
= libcap host-pkgconf
12 LXC_CONF_OPTS
= --disable-apparmor
--with-distro
=buildroot \
13 --disable-python
--disable-werror \
14 $(if
$(BR2_PACKAGE_BASH
),,--disable-bash
)
16 ifeq ($(BR2_PACKAGE_LIBSECCOMP
),y
)
17 LXC_CONF_OPTS
+= --enable-seccomp
18 LXC_DEPENDENCIES
+= libseccomp
20 LXC_CONF_OPTS
+= --disable-seccomp
23 ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER
),y
)
24 LXC_CONF_OPTS
+= --enable-lua
25 LXC_DEPENDENCIES
+= luainterpreter
26 ifeq ($(BR2_PACKAGE_LUAJIT
),y
)
27 # By default, lxc will only search for lua.pc
28 LXC_CONF_OPTS
+= --with-lua-pc
=luajit
31 LXC_CONF_OPTS
+= --disable-lua
34 $(eval
$(autotools-package
))