toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / matchbox / matchbox.mk
blob9094b1ec63062fb227e67d90a188820193e607b7
1 ################################################################################
3 # matchbox
5 ################################################################################
7 MATCHBOX_VERSION = 1.2
8 MATCHBOX_SOURCE = matchbox-window-manager-$(MATCHBOX_VERSION).tar.bz2
9 MATCHBOX_SITE = http://downloads.yoctoproject.org/releases/matchbox/matchbox-window-manager/$(MATCHBOX_VERSION)
10 MATCHBOX_LICENSE = GPLv2+
11 MATCHBOX_LICENSE_FILES = COPYING
13 MATCHBOX_DEPENDENCIES = matchbox-lib
14 MATCHBOX_CONF_OPTS = \
15 --enable-expat \
16 --disable-gconf \
17 --disable-composite \
18 --disable-standalone \
19 --disable-standalone-xft
21 # Workaround bug in configure script
22 MATCHBOX_CONF_ENV = expat=yes
24 ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
25 MATCHBOX_CONF_OPTS += --enable-startup-notification
26 MATCHBOX_DEPENDENCIES += startup-notification
27 else
28 MATCHBOX_CONF_OPTS += --disable-startup-notification
29 endif
31 ifeq ($(BR2_PACKAGE_MATCHBOX_SM),y)
32 MATCHBOX_CONF_OPTS += --enable-session
33 MATCHBOX_DEPENDENCIES += xlib_libSM
34 else
35 MATCHBOX_CONF_OPTS += --disable-session
36 endif
38 ifeq ($(BR2_PACKAGE_XLIB_LIBXCURSOR),y)
39 MATCHBOX_DEPENDENCIES += xlib_libXcursor
40 endif
42 ifeq ($(BR2_PACKAGE_XLIB_LIBXFIXES),y)
43 MATCHBOX_DEPENDENCIES += xlib_libXfixes
44 endif
46 $(eval $(autotools-package))