toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / pixman / pixman.mk
blobc797b3e60cd53a7788ae53d7df2bb9bac9d48846
1 ################################################################################
3 # pixman
5 ################################################################################
7 PIXMAN_VERSION = 0.34.0
8 PIXMAN_SOURCE = pixman-$(PIXMAN_VERSION).tar.bz2
9 PIXMAN_SITE = http://xorg.freedesktop.org/releases/individual/lib
10 PIXMAN_LICENSE = MIT
11 PIXMAN_LICENSE_FILES = COPYING
13 PIXMAN_INSTALL_STAGING = YES
14 PIXMAN_DEPENDENCIES = host-pkgconf
15 HOST_PIXMAN_DEPENDENCIES = host-pkgconf
17 # For 0001-Disable-tests.patch
18 PIXMAN_AUTORECONF = YES
20 # don't build gtk based demos
21 PIXMAN_CONF_OPTS = --disable-gtk
23 # The ARM SIMD code from pixman requires a recent enough ARM core, but
24 # there is a runtime CPU check that makes sure it doesn't get used if
25 # the HW doesn't support it. The only case where the ARM SIMD code
26 # cannot be *built* at all is when the platform doesn't support ARM
27 # instructions at all, so we have to disable that explicitly.
28 ifeq ($(BR2_ARM_CPU_HAS_ARM),y)
29 PIXMAN_CONF_OPTS += --enable-arm-simd
30 else
31 PIXMAN_CONF_OPTS += --disable-arm-simd
32 endif
34 ifeq ($(BR2_ARM_CPU_HAS_ARM)$(BR2_ARM_CPU_HAS_NEON),yy)
35 PIXMAN_CONF_OPTS += --enable-arm-neon
36 else
37 PIXMAN_CONF_OPTS += --disable-arm-neon
38 endif
40 # disable iwmmxt support for CPU's that don't have
41 # this feature
42 ifneq ($(BR2_iwmmxt),y)
43 PIXMAN_CONF_OPTS += --disable-arm-iwmmxt
44 endif
46 # toolchain gets confused about TLS access through GOT (PIC), so disable TLS
47 # movhi r4, %got_hiadj(%tls_ldo(fast_path_cache))
48 # {standard input}:172: Error: bad expression
49 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII),y)
50 PIXMAN_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -DPIXMAN_NO_TLS"
51 endif
53 $(eval $(autotools-package))
54 $(eval $(host-autotools-package))