toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / proftpd / proftpd.mk
bloba70f41ef793e5a7d161ce7612294876161f4a752
1 ################################################################################
3 # proftpd
5 ################################################################################
7 PROFTPD_VERSION = 1.3.5b
8 PROFTPD_SOURCE = proftpd-$(PROFTPD_VERSION).tar.gz
9 PROFTPD_SITE = ftp://ftp.proftpd.org/distrib/source
10 PROFTPD_LICENSE = GPLv2+
11 PROFTPD_LICENSE_FILES = COPYING
13 PROFTPD_CONF_ENV = \
14 ac_cv_func_setpgrp_void=yes \
15 ac_cv_func_setgrent_void=yes
17 PROFTPD_CONF_OPTS = \
18 --localstatedir=/var/run \
19 --disable-static \
20 --disable-curses \
21 --disable-ncurses \
22 --disable-facl \
23 --disable-dso \
24 --enable-shadow \
25 --with-gnu-ld
27 ifeq ($(BR2_PACKAGE_PROFTPD_MOD_REWRITE),y)
28 PROFTPD_CONF_OPTS += --with-modules=mod_rewrite
29 endif
31 # configure script doesn't handle detection of %llu format string
32 # support for printing the file size when cross compiling, breaking
33 # access for large files.
34 # We unfortunately cannot AUTORECONF the package, so instead force it
35 # on if we know we support it
36 define PROFTPD_USE_LLU
37 $(SED) 's/HAVE_LU/HAVE_LLU/' $(@D)/configure
38 endef
39 PROFTPD_PRE_CONFIGURE_HOOKS += PROFTPD_USE_LLU
41 define PROFTPD_MAKENAMES
42 $(MAKE1) CC="$(HOSTCC)" CFLAGS="" LDFLAGS="" -C $(@D)/lib/libcap _makenames
43 endef
45 PROFTPD_POST_CONFIGURE_HOOKS = PROFTPD_MAKENAMES
47 PROFTPD_MAKE = $(MAKE1)
49 define PROFTPD_INSTALL_TARGET_CMDS
50 $(INSTALL) -D -m 0755 $(@D)/proftpd $(TARGET_DIR)/usr/sbin/proftpd
51 $(INSTALL) -m 0644 -D $(@D)/sample-configurations/basic.conf $(TARGET_DIR)/etc/proftpd.conf
52 endef
54 define PROFTPD_USERS
55 ftp -1 ftp -1 * /home/ftp - - Anonymous FTP User
56 endef
58 define PROFTPD_INSTALL_INIT_SYSV
59 $(INSTALL) -D -m 0755 package/proftpd/S50proftpd $(TARGET_DIR)/etc/init.d/S50proftpd
60 endef
62 define PROFTPD_INSTALL_INIT_SYSTEMD
63 $(INSTALL) -D -m 644 package/proftpd/proftpd.service \
64 $(TARGET_DIR)/usr/lib/systemd/system/proftpd.service
65 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
66 ln -sf ../../../../usr/lib/systemd/system/proftpd.service \
67 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/proftpd.service
68 endef
70 $(eval $(autotools-package))