toolchain: bump Codescape IMG MIPS version to 2016.05-06
[buildroot-gz.git] / package / rrdtool / rrdtool.mk
blobabca1d80f516d77659c89a9249eccfe1dc7a58fe
1 ################################################################################
3 # rrdtool
5 ################################################################################
7 RRDTOOL_VERSION = 1.6.0
8 RRDTOOL_SITE = http://oss.oetiker.ch/rrdtool/pub
9 RRDTOOL_LICENSE = GPLv2+ with FLOSS license exceptions as explained in COPYRIGHT
10 RRDTOOL_LICENSE_FILES = COPYRIGHT LICENSE
11 RRDTOOL_DEPENDENCIES = host-pkgconf libglib2
12 # autoreconf needed to avoid link failure due to missing -lintl,
13 # gettextize needed as a consequence of autoreconf
14 RRDTOOL_AUTORECONF = YES
15 RRDTOOL_GETTEXTIZE = YES
16 RRDTOOL_INSTALL_STAGING = YES
17 RRDTOOL_CONF_OPTS = \
18 --disable-examples \
19 --disable-libdbi \
20 --disable-librados \
21 --disable-libwrap \
22 --disable-lua \
23 --disable-perl \
24 --disable-python \
25 --disable-ruby \
26 --disable-tcl
29 ifeq ($(BR2_NEEDS_GETTEXT),y)
30 RRDTOOL_DEPENDENCIES += gettext
31 endif
33 ifeq ($(BR2_PACKAGE_RRDTOOL_RRDGRAPH),y)
34 RRDTOOL_DEPENDENCIES += cairo pango
35 else
36 RRDTOOL_CONF_OPTS += --disable-rrd_graph
37 endif
39 ifeq ($(BR2_PACKAGE_LIBXML2),y)
40 RRDTOOL_DEPENDENCIES += libxml2
41 else
42 RRDTOOL_CONF_OPTS += --disable-rrd_restore
43 endif
45 $(eval $(autotools-package))