1 ################################################################################
5 ################################################################################
8 NEON_SITE
= http
://www.webdav.org
/neon
9 NEON_LICENSE
= LGPLv2
+ (library
), GPLv2
+ (manual and tests
)
10 NEON_LICENSE_FILES
= src
/COPYING.LIB
test/COPYING README
11 NEON_INSTALL_STAGING
= YES
12 NEON_CONF_OPTS
= --without-gssapi
--disable-rpath
13 NEON_CONFIG_SCRIPTS
= neon-config
14 NEON_DEPENDENCIES
= host-pkgconf
16 ifeq ($(BR2_PACKAGE_NEON_ZLIB
),y
)
17 NEON_CONF_OPTS
+= --with-zlib
=$(STAGING_DIR
)
18 NEON_DEPENDENCIES
+= zlib
20 NEON_CONF_OPTS
+= --without-zlib
23 ifeq ($(BR2_PACKAGE_NEON_SSL
),y
)
24 NEON_CONF_OPTS
+= --with-ssl
25 NEON_DEPENDENCIES
+= openssl
27 NEON_CONF_OPTS
+= --without-ssl
30 ifeq ($(BR2_PACKAGE_NEON_EXPAT
),y
)
31 NEON_CONF_OPTS
+= --with-expat
=yes
32 NEON_DEPENDENCIES
+= expat
34 NEON_CONF_OPTS
+= --with-expat
=no
37 ifeq ($(BR2_PACKAGE_NEON_LIBXML2
),y
)
38 NEON_CONF_OPTS
+= --with-libxml2
=yes
39 NEON_CONF_ENV
+= ac_cv_prog_XML2_CONFIG
=$(STAGING_DIR
)/usr
/bin
/xml2-config
40 NEON_DEPENDENCIES
+= libxml2
42 NEON_CONF_OPTS
+= --with-libxml2
=no
45 ifeq ($(BR2_PACKAGE_NEON_EXPAT
)$(BR2_PACKAGE_NEON_LIBXML2
),)
46 # webdav needs xml support
47 NEON_CONF_OPTS
+= --disable-webdav
50 $(eval
$(autotools-package
))