1 ################################################################################
5 ################################################################################
7 # See note below when updating Erlang
9 ERLANG_SITE
= http
://www.erlang.org
/download
10 ERLANG_SOURCE
= otp_src_
$(ERLANG_VERSION
).
tar.gz
11 ERLANG_DEPENDENCIES
= host-erlang
13 ERLANG_LICENSE
= Apache-2.0
14 ERLANG_LICENSE_FILES
= LICENSE.txt
15 ERLANG_INSTALL_STAGING
= YES
17 # Patched erts/aclocal.m4
18 ERLANG_AUTORECONF
= YES
20 # Whenever updating Erlang, this value should be updated as well, to the
21 # value of EI_VSN in the file lib/erl_interface/vsn.mk
24 # The configure checks for these functions fail incorrectly
25 ERLANG_CONF_ENV
= ac_cv_func_isnan
=yes ac_cv_func_isinf
=yes
27 # Set erl_xcomp variables. See xcomp/erl-xcomp.conf.template
29 ERLANG_CONF_ENV
+= erl_xcomp_sysroot
=$(STAGING_DIR
)
31 ERLANG_CONF_OPTS
= --without-javac
33 # erlang uses openssl for all things crypto. Since the host tools (such as
34 # rebar) uses crypto, we need to build host-erlang with support for openssl.
35 HOST_ERLANG_DEPENDENCIES
= host-openssl
36 HOST_ERLANG_CONF_OPTS
= --without-javac
--with-ssl
=$(HOST_DIR
)/usr
38 HOST_ERLANG_CONF_OPTS
+= --without-termcap
40 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS
),)
41 ERLANG_CONF_OPTS
+= --disable-threads
44 ifeq ($(BR2_PACKAGE_NCURSES
),y
)
45 ERLANG_CONF_OPTS
+= --with-termcap
46 ERLANG_DEPENDENCIES
+= ncurses
48 ERLANG_CONF_OPTS
+= --without-termcap
51 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
52 ERLANG_CONF_OPTS
+= --with-ssl
53 ERLANG_DEPENDENCIES
+= openssl
55 ERLANG_CONF_OPTS
+= --without-ssl
58 # ODBC support in erlang requires threads
59 ifeq ($(BR2_PACKAGE_UNIXODBC
)$(BR2_TOOLCHAIN_HAS_THREADS
),yy
)
60 ERLANG_DEPENDENCIES
+= unixodbc
61 ERLANG_CONF_OPTS
+= --with-odbc
63 ERLANG_CONF_OPTS
+= --without-odbc
66 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
67 ERLANG_CONF_OPTS
+= --enable-shared-zlib
68 ERLANG_DEPENDENCIES
+= zlib
71 ifeq ($(BR2_PACKAGE_ERLANG_SMP
),)
72 ERLANG_CONF_OPTS
+= --disable-smp-support
75 # Remove source, example, gs and wx files from staging and target.
76 ERLANG_REMOVE_PACKAGES
= gs wx
78 ifneq ($(BR2_PACKAGE_ERLANG_MEGACO
),y
)
79 ERLANG_REMOVE_PACKAGES
+= megaco
82 define ERLANG_REMOVE_STAGING_UNUSED
83 for package in
$(ERLANG_REMOVE_PACKAGES
); do \
84 rm -rf
$(STAGING_DIR
)/usr
/lib
/erlang
/lib
/$${package}-*; \
88 define ERLANG_REMOVE_TARGET_UNUSED
89 find
$(TARGET_DIR
)/usr
/lib
/erlang
-type d
-name src
-prune
-exec
rm -rf
{} \
;
90 find
$(TARGET_DIR
)/usr
/lib
/erlang
-type d
-name examples
-prune
-exec
rm -rf
{} \
;
91 for package in
$(ERLANG_REMOVE_PACKAGES
); do \
92 rm -rf
$(TARGET_DIR
)/usr
/lib
/erlang
/lib
/$${package}-*; \
96 ERLANG_POST_INSTALL_STAGING_HOOKS
+= ERLANG_REMOVE_STAGING_UNUSED
97 ERLANG_POST_INSTALL_TARGET_HOOKS
+= ERLANG_REMOVE_TARGET_UNUSED
99 $(eval
$(autotools-package
))
100 $(eval
$(host-autotools-package
))