1 ################################################################################
5 ################################################################################
7 HEIMDAL_VERSION
= 7.1.0
8 HEIMDAL_SITE
= http
://www.h5l.org
/dist/src
9 HOST_HEIMDAL_DEPENDENCIES
= host-e2fsprogs host-ncurses host-pkgconf
10 HEIMDAL_INSTALL_STAGING
= YES
11 HEIMDAL_MAKE
= $(MAKE1
)
12 # static because of -fPIC issues with e2fsprogs on x86_64 host
13 HOST_HEIMDAL_CONF_OPTS
= \
21 --without-berkeley-db \
26 --disable-heimdal-documentation
27 HOST_HEIMDAL_CONF_ENV
= MAKEINFO
=true
28 HEIMDAL_LICENSE
= BSD-3c
29 HEIMDAL_LICENSE_FILES
= LICENSE
31 # We need asn1_compile in the PATH for samba4
32 define HOST_HEIMDAL_MAKE_SYMLINK
33 ln
-sf
$(HOST_DIR
)/usr
/libexec
/heimdal
/asn1_compile \
34 $(HOST_DIR
)/usr
/bin
/asn1_compile
35 ln
-sf
$(HOST_DIR
)/usr
/bin
/compile_et \
36 $(HOST_DIR
)/usr
/libexec
/heimdal
/compile_et
39 HOST_HEIMDAL_POST_INSTALL_HOOKS
+= HOST_HEIMDAL_MAKE_SYMLINK
41 $(eval
$(host-autotools-package
))