kmod: bump to version 24
[buildroot-gz.git] / package / ramsmp / ramsmp.mk
blob6098376da596725969bc42341b69b09385a0079c
1 ################################################################################
3 # ramsmp
5 ################################################################################
7 RAMSMP_VERSION = 3.5.0
8 RAMSMP_SITE = http://www.alasir.com/software/ramspeed
9 RAMSMP_ARCH = $(if $(BR2_i386),i386)$(if $(BR2_x86_64),x86_64)
10 RAMSMP_LICENSE = Alasir License
11 RAMSMP_LICENSE_FILES = LICENCE
13 define RAMSMP_BUILD_CMDS
14 cp -f package/ramsmp/Makefile $(@D)
15 $(TARGET_CONFIGURE_OPTS) make -C $(@D) $(RAMSMP_ARCH)
16 endef
18 define RAMSMP_INSTALL_TARGET_CMDS
19 $(INSTALL) -m 0755 -D $(@D)/ramsmp $(TARGET_DIR)/usr/bin/ramsmp
20 endef
22 $(eval $(generic-package))