1 ################################################################################
5 ################################################################################
8 DILLO_SOURCE
= dillo-
$(DILLO_VERSION
).
tar.bz2
9 DILLO_SITE
= http
://www.dillo.org
/download
10 DILLO_LICENSE
= GPLv3
+
11 DILLO_LICENSE_FILES
= COPYING
12 # configure.ac gets patched, so autoreconf is necessary
13 DILLO_AUTORECONF
= YES
14 DILLO_DEPENDENCIES
= fltk zlib \
15 $(if
$(BR2_PACKAGE_LIBICONV
),libiconv
)
16 DILLO_CONF_ENV
= ac_cv_path_FLTK_CONFIG
=$(STAGING_DIR
)/usr
/bin
/fltk-config
18 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
19 DILLO_CONF_OPTS
+= --enable-ssl
20 DILLO_DEPENDENCIES
+= openssl
22 DILLO_CONF_OPTS
+= --disable-ssl
25 ifeq ($(BR2_PACKAGE_LIBPNG
),y
)
26 DILLO_CONF_OPTS
+= --enable-png
27 DILLO_DEPENDENCIES
+= libpng
28 DILLO_CONF_ENV
+= PNG_CONFIG
=$(STAGING_DIR
)/usr
/bin
/libpng-config
30 DILLO_CONF_OPTS
+= --disable-png
33 ifeq ($(BR2_PACKAGE_JPEG
),y
)
34 DILLO_CONF_OPTS
+= --enable-jpeg
35 DILLO_DEPENDENCIES
+= jpeg
37 DILLO_CONF_OPTS
+= --disable-jpeg
40 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS
),y
)
41 DILLO_CONF_OPTS
+= --enable-threaded-dns
43 DILLO_CONF_OPTS
+= --disable-threaded-dns
46 $(eval
$(autotools-package
))