1 ################################################################################
5 ################################################################################
7 PYTHON_JINJA2_VERSION
= 2.9.4
8 PYTHON_JINJA2_SOURCE
= Jinja2-
$(PYTHON_JINJA2_VERSION
).
tar.gz
9 PYTHON_JINJA2_SITE
= https
://pypi.python.org
/packages
/f4
/3f
/28387a5bbc6883082c16784c6135440b94f9d5938fb156ff579798e18eda
10 PYTHON_JINJA2_SETUP_TYPE
= setuptools
11 PYTHON_JINJA2_LICENSE
= BSD-3c
12 PYTHON_JINJA2_LICENSE_FILES
= LICENSE
13 # In host build, setup.py tries to download markupsafe if it is not installed
14 HOST_PYTHON_JINJA2_DEPENDENCIES
= host-python-markupsafe
16 # Both asyncsupport.py and asyncfilters.py use async feature, that is
17 # not available in Python 2 and some features available in Python 3.6.
18 # So in both cases *.py compilation would produce compiler errors.
19 # Hence remove both files after package extraction.
20 define PYTHON_JINJA2_REMOVE_ASYNC_SUPPORT
21 rm $(@D
)/jinja2
/asyncsupport.py
$(@D
)/jinja2
/asyncfilters.py
24 PYTHON_JINJA2_POST_EXTRACT_HOOKS
= PYTHON_JINJA2_REMOVE_ASYNC_SUPPORT
26 $(eval
$(python-package
))
27 $(eval
$(host-python-package
))