iperf3: bump to version 3.1.2
[buildroot-gz.git] / package / libuv / libuv.mk
blob45b301f68a8b4ff785c6ec0a1f77f41a61c58fdf
1 ################################################################################
3 # libuv
5 ################################################################################
7 LIBUV_VERSION = v1.9.0
8 LIBUV_SITE = $(call github,libuv,libuv,$(LIBUV_VERSION))
9 LIBUV_DEPENDENCIES = host-pkgconf
10 LIBUV_INSTALL_STAGING = YES
11 LIBUV_AUTORECONF = YES
12 LIBUV_LICENSE = BSD-2c, BSD-3c, ISC, MIT
13 LIBUV_LICENSE_FILES = LICENSE
15 # Upstream needs tests to be run sequentially. This is the default in
16 # automake 1.11 and before, but not starting in 1.12. To maintain
17 # sequentiality in 1.12 and later, the automake option 'serial-tests'
18 # must be used, Unfortunately, it is not recognised by 1.11 and
19 # before. So upstream only adds it conditionally. We use automake
20 # 1.14, so we need it.
21 define LIBUV_FIXUP_AUTOGEN
22 echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
23 >$(@D)/m4/libuv-extra-automake-flags.m4
24 endef
25 LIBUV_POST_PATCH_HOOKS += LIBUV_FIXUP_AUTOGEN
27 $(eval $(autotools-package))