libasplib: add url to gcc bug report
[buildroot-gz.git] / package / openntpd / openntpd.mk
blob9c98064c7a0c9e5665513c78bde21cca4b2e6bd9
1 ################################################################################
3 # openntpd
5 ################################################################################
7 OPENNTPD_VERSION = 6.0p1
8 OPENNTPD_SITE = http://ftp.openbsd.org/pub/OpenBSD/OpenNTPD
9 OPENNTPD_LICENSE = MIT-like, BSD-2c, BSD-3c
10 OPENNTPD_LICENSE_FILES = COPYING
11 # Ships a beta libtool version hence our patch doesn't apply.
12 OPENNTPD_AUTORECONF = YES
14 # openntpd uses pthread functions for arc4random emulation but forgets
15 # to use -pthread
16 OPENNTPD_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -pthread"
18 define OPENNTPD_INSTALL_INIT_SYSTEMD
19 $(INSTALL) -D -m 0644 package/openntpd/ntpd.service \
20 $(TARGET_DIR)/usr/lib/systemd/system/ntpd.service
21 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
22 ln -fs ../../../../usr/lib/systemd/system/ntpd.service \
23 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ntpd.service
24 endef
26 define OPENNTPD_INSTALL_INIT_SYSV
27 $(INSTALL) -m 0755 -D package/openntpd/S49ntp \
28 $(TARGET_DIR)/etc/init.d/S49ntp
29 endef
31 define OPENNTPD_USERS
32 _ntp -1 _ntp -1 * - - - Network Time Protocol daemon
33 endef
35 $(eval $(autotools-package))