1 ################################################################################
5 ################################################################################
7 JANUS_GATEWAY_VERSION
= v0.2
.1
8 JANUS_GATEWAY_SITE
= $(call github
,meetecho
,janus-gateway
,$(JANUS_GATEWAY_VERSION
))
9 JANUS_GATEWAY_LICENSE
= GPLv3
10 JANUS_GATEWAY_LICENSE_FILES
= COPYING
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES
= host-pkgconf jansson libnice \
14 libsrtp host-gengetopt libglib2 openssl
16 # Straight out of the repository, no ./configure, and we also patch
18 JANUS_GATEWAY_AUTORECONF
= YES
20 define JANUS_GATEWAY_M4
23 JANUS_GATEWAY_POST_PATCH_HOOKS
+= JANUS_GATEWAY_M4
25 JANUS_GATEWAY_CONF_OPTS
= \
26 --disable-data-channels \
29 ifeq ($(BR2_PACKAGE_JANUS_AUDIO_BRIDGE
),y
)
30 JANUS_GATEWAY_DEPENDENCIES
+= opus
31 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-audiobridge
33 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-audiobridge
36 ifeq ($(BR2_PACKAGE_JANUS_ECHO_TEST
),y
)
37 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-echotest
39 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-echotest
42 ifeq ($(BR2_PACKAGE_JANUS_RECORDPLAY
),y
)
43 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-recordplay
45 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-recordplay
48 ifeq ($(BR2_PACKAGE_JANUS_SIP_GATEWAY
),y
)
49 JANUS_GATEWAY_DEPENDENCIES
+= sofia-sip
50 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-sip
52 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-sip
55 ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS
),y
)
56 JANUS_GATEWAY_DEPENDENCIES
+= libwebsockets
57 JANUS_GATEWAY_CONF_OPTS
+= --enable-websockets
59 JANUS_GATEWAY_CONF_OPTS
+= --disable-websockets
62 ifeq ($(BR2_PACKAGE_LIBOGG
),y
)
63 JANUS_GATEWAY_DEPENDENCIES
+= libogg
64 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-voicemail
66 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-voicemail
69 # Parallel build broken
70 JANUS_GATEWAY_MAKE
= $(MAKE1
)
72 $(eval
$(autotools-package
))