1 ################################################################################
5 ################################################################################
7 TARGETCLI_FB_VERSION
= v2.1.fb41
8 TARGETCLI_FB_SITE
= $(call github
,agrover
,targetcli-fb
,$(TARGETCLI_FB_VERSION
))
9 TARGETCLI_FB_LICENSE
= Apache-2.0
10 TARGETCLI_FB_LICENSE_FILES
= COPYING
11 TARGETCLI_FB_SETUP_TYPE
= setuptools
12 TARGETCLI_FB_DEPENDENCIES
= python-configshell-fb python-rtslib-fb python-six
14 define TARGETCLI_FB_INSTALL_INIT_SYSV
15 $(INSTALL
) -m
0755 -D package
/targetcli-fb
/S50target \
16 $(TARGET_DIR
)/etc
/init.d
/S50target
19 define TARGETCLI_FB_INSTALL_INIT_SYSTEMD
20 $(INSTALL
) -m
0644 -D package
/targetcli-fb
/target.service \
21 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/target.service
24 # Targetcli stores its configuration in /etc/target/saveconfig.json
25 # and complains if the /etc/target/ directory does not exist.
26 define TARGETCLI_FB_INSTALL_CONF_DIR
27 $(INSTALL
) -m
0755 -d
$(TARGET_DIR
)/etc
/target
30 TARGETCLI_FB_POST_INSTALL_TARGET_HOOKS
+= TARGETCLI_FB_INSTALL_CONF_DIR
32 $(eval
$(python-package
))