harfbuzz: security bump to version 1.4.4
[buildroot-gz.git] / package / gauche / gauche.mk
blob85fcc7184863cb8e1236d6ac899c2bc4d40ba1fa
1 ################################################################################
3 # gauche
5 ################################################################################
7 GAUCHE_VERSION = 0.9.4
8 GAUCHE_SOURCE = Gauche-$(GAUCHE_VERSION).tgz
9 GAUCHE_SITE = http://downloads.sourceforge.net/project/gauche/Gauche
10 GAUCHE_LICENSE = BSD-3c, Boehm-gc, SRFI (srfi-11.scm), reload (reload.scm)
11 GAUCHE_LICENSE_FILES = COPYING
12 GAUCHE_DEPENDENCIES = host-gauche
13 GAUCHE_PATCH = https://github.com/shirok/Gauche/commit/13a196557848f22a1607a300643131345e9f32b3.patch
15 HOST_GAUCHE_CONF_OPTS = --without-zlib
16 GAUCHE_CONF_OPTS = --without-libatomic-ops
18 ifeq ($(BR2_PACKAGE_ZLIB),y)
19 GAUCHE_CONF_OPTS += --with-zlib=$(STAGING_DIR)
20 GAUCHE_DEPENDENCIES += zlib
21 else
22 GAUCHE_CONF_OPTS += --without-zlib
23 endif
25 # Detection of c99 support in configure fails without WCHAR. To enable
26 # automatic detection of c99 support by configure, we need to enable
27 # WCHAR in toolchain. But actually we do not need WCHAR at gauche
28 # runtime. So reuesting WCHAR in toolchain just for automatic detection
29 # will be overkill. To solve this, explicitly -std=gnu99 is specified
30 # here.
31 GAUCHE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
33 $(eval $(host-autotools-package))
34 $(eval $(autotools-package))