harfbuzz: security bump to version 1.4.4
[buildroot-gz.git] / package / ibrdtnd / ibrdtnd.mk
blob0632ed36b7db899120f82a2fc90445612d0447ca
1 ################################################################################
3 # ibrdtnd
5 ################################################################################
7 IBRDTND_VERSION = 1.0.1
8 IBRDTND_SITE = https://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
9 IBRDTND_LICENSE = Apache-2.0
10 IBRDTND_LICENSE_FILES = COPYING
11 IBRDTND_DEPENDENCIES = ibrdtn ibrcommon host-pkgconf
13 # Disable features that don't have the necessary dependencies in
14 # Buildroot
15 IBRDTND_CONF_OPTS = \
16 --disable-dtndht \
17 --without-wifip2p \
18 --without-vmime
20 # don't build documentation
21 IBRDTND_CONF_ENV = PDFLATEX='no'
23 ifeq ($(BR2_PACKAGE_LIBDAEMON),y)
24 IBRDTND_CONF_OPTS += --enable-libdaemon
25 IBRDTND_DEPENDENCIES += libdaemon
26 else
27 IBRDTND_CONF_OPTS += --disable-libdaemon
28 endif
30 ifeq ($(BR2_PACKAGE_LIBCURL),y)
31 IBRDTND_CONF_OPTS += --with-curl
32 IBRDTND_DEPENDENCIES += libcurl
33 else
34 IBRDTND_CONF_OPTS += --without-curl
35 endif
37 ifeq ($(BR2_PACKAGE_SQLITE),y)
38 IBRDTND_CONF_OPTS += --with-sqlite
39 IBRDTND_DEPENDENCIES += sqlite
40 else
41 IBRDTND_CONF_OPTS += --without-sqlite
42 endif
44 ifeq ($(BR2_PACKAGE_OPENSSL),y)
45 IBRDTND_CONF_OPTS += --with-tls
46 IBRDTND_DEPENDENCIES += openssl
47 else
48 IBRDTND_CONF_OPTS += --without-tls
49 endif
51 $(eval $(autotools-package))