harfbuzz: security bump to version 1.4.4
[buildroot-gz.git] / package / sdl2_ttf / sdl2_ttf.mk
blob86916c3443a23f287867a07d45ee96576507c411
1 ################################################################################
3 # sdl2_ttf
5 ################################################################################
7 SDL2_TTF_VERSION = 2.0.14
8 SDL2_TTF_SOURCE = SDL2_ttf-$(SDL2_TTF_VERSION).tar.gz
9 SDL2_TTF_SITE = http://www.libsdl.org/projects/SDL_ttf/release
10 SDL2_TTF_LICENSE = zlib
11 SDL2_TTF_LICENSE_FILES = COPYING.txt
12 SDL2_TTF_INSTALL_STAGING = YES
13 SDL2_TTF_DEPENDENCIES = sdl2 freetype host-pkgconf
15 # Two patches touching configure.in
16 SDL2_TTF_AUTORECONF = YES
18 SDL2_TTF_CONF_ENV = \
19 FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
21 # x-includes and x-libraries must be set for cross-compiling
22 # By default x_includes and x_libraries contains unsafe paths.
23 # (/usr/include and /usr/lib)
24 ifeq ($(BR2_PACKAGE_SDL2_X11),y)
25 SDL2_TTF_CONF_OPTS += \
26 --with-x \
27 --x-includes=$(STAGING_DIR)/usr/include \
28 --x-libraries=$(STAGING_DIR)/usr/lib
29 else
30 SDL2_TTF_CONF_OPTS += \
31 --without-x
32 endif
34 $(eval $(autotools-package))