harfbuzz: security bump to version 1.4.4
[buildroot-gz.git] / package / tcpreplay / tcpreplay.mk
bloba8bcf1c5dd9997de5fc20d5374f8c6355c2a3631
1 ################################################################################
3 # tcpreplay
5 ################################################################################
7 TCPREPLAY_VERSION = 4.1.2
8 TCPREPLAY_SITE = https://github.com/appneta/tcpreplay/releases/download/v$(TCPREPLAY_VERSION)
9 TCPREPLAY_LICENSE = GPLv3
10 TCPREPLAY_LICENSE_FILES = docs/LICENSE
11 TCPREPLAY_CONF_ENV = \
12 tr_cv_libpcap_version=">= 0.7.0" \
13 ac_cv_have_bpf=no \
14 $(call AUTOCONF_AC_CHECK_FILE_VAL,$(STAGING_DIR)/usr/include/pcap-netmap.c)=no
15 TCPREPLAY_CONF_OPTS = --with-libpcap=$(STAGING_DIR)/usr
16 TCPREPLAY_DEPENDENCIES = libpcap
18 # libpcap may depend on symbols in other libs
19 TCPREPLAY_LIBS = $(STAGING_DIR)/usr/bin/pcap-config --static --libs
20 TCPREPLAY_CONF_ENV += ac_cv_search_pcap_close="`$(TCPREPLAY_LIBS)`" \
21 LIBS="`$(TCPREPLAY_LIBS)`"
23 ifeq ($(BR2_STATIC_LIBS),y)
24 TCPREPLAY_CONF_OPTS += --enable-dynamic-link=no
25 endif
27 ifeq ($(BR2_PACKAGE_TCPDUMP),y)
28 TCPREPLAY_CONF_ENV += ac_cv_path_tcpdump_path=/usr/sbin/tcpdump
29 else
30 TCPREPLAY_CONF_ENV += ac_cv_path_tcpdump_path=no
31 endif
33 $(eval $(autotools-package))