harfbuzz: security bump to version 1.4.4
[buildroot-gz.git] / package / zeromq / zeromq.mk
blob5c99983b537ed4e55fdc666056ce105bb5d2ce30
1 ################################################################################
3 # zeromq
5 ################################################################################
7 ZEROMQ_VERSION = 4.1.5
8 ZEROMQ_SITE = https://github.com/zeromq/zeromq4-1/releases/download/v$(ZEROMQ_VERSION)
9 ZEROMQ_INSTALL_STAGING = YES
10 ZEROMQ_DEPENDENCIES = util-linux
11 ZEROMQ_CONF_OPTS = --without-documentation
12 ZEROMQ_LICENSE = LGPLv3+ with exceptions
13 ZEROMQ_LICENSE_FILES = COPYING COPYING.LESSER
14 # For 0001-acinclude.m4-make-kernel-specific-flags-cacheable.patch
15 ZEROMQ_AUTORECONF = YES
17 # Assume these flags are always available. It is true, at least for
18 # SOCK_CLOEXEC, since linux v2.6.27.
19 # Note: the flag TCP_KEEPALIVE is NOT available so we do not include it.
20 ZEROMQ_CONF_ENV = libzmq_cv_sock_cloexec=yes \
21 libzmq_cv_so_keepalive=yes \
22 libzmq_cv_tcp_keepcnt=yes \
23 libzmq_cv_tcp_keepidle=yes \
24 libzmq_cv_tcp_keepintvl=yes
26 # Only tools/curve_keygen.c needs this, but it doesn't hurt to pass it
27 # for the rest of the build as well (which automatically includes stdc++).
28 ifeq ($(BR2_STATIC_LIBS),y)
29 ZEROMQ_CONF_OPTS += LIBS=-lstdc++
30 endif
32 ifeq ($(BR2_PACKAGE_ZEROMQ_NORM),y)
33 ZEROMQ_CONF_OPTS += --with-norm
34 ZEROMQ_DEPENDENCIES += norm
35 else
36 ZEROMQ_CONF_OPTS += --without-norm
37 endif
39 ifeq ($(BR2_PACKAGE_ZEROMQ_PGM),y)
40 ZEROMQ_DEPENDENCIES += host-pkgconf openpgm
41 ZEROMQ_CONF_OPTS += --with-pgm
42 else
43 ZEROMQ_CONF_OPTS += --without-pgm
44 endif
46 # ZeroMQ uses libsodium if it's available.
47 ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
48 ZEROMQ_DEPENDENCIES += libsodium
49 ZEROMQ_CONF_OPTS += --with-libsodium="$(STAGING_DIR)/usr"
50 else
51 ZEROMQ_CONF_OPTS += --without-libsodium
52 endif
54 $(eval $(autotools-package))