linux-headers: bump 4.{4, 9}.x series
[buildroot-gz.git] / package / openobex / openobex.mk
blob6a1a10ba4f0198900c7443543d6f37ce33ec633d
1 ################################################################################
3 # openobex
5 ################################################################################
7 OPENOBEX_VERSION_MAJOR = 1.5
8 OPENOBEX_VERSION = $(OPENOBEX_VERSION_MAJOR).0
9 OPENOBEX_SITE = http://downloads.sourceforge.net/project/openobex/openobex/$(OPENOBEX_VERSION_MAJOR)
10 OPENOBEX_SOURCE = openobex-$(OPENOBEX_VERSION)-Source.zip
11 # Libraries seems to be released under LGPLv2.1+,
12 # while other material is under GPLv2+.
13 OPENOBEX_LICENSE = GPLv2+/LGPLv2.1+
14 OPENOBEX_LICENSE_FILES = COPYING COPYING.LIB
16 OPENOBEX_DEPENDENCIES = host-pkgconf
17 OPENOBEX_AUTORECONF = YES
18 OPENOBEX_INSTALL_STAGING = YES
20 define OPENOBEX_EXTRACT_CMDS
21 $(UNZIP) -d $(@D) $(DL_DIR)/$(OPENOBEX_SOURCE)
22 mv $(@D)/openobex-$(OPENOBEX_VERSION)-Source/* $(@D)
23 $(RM) -r $(@D)/openobex-$(OPENOBEX_VERSION)-Source
24 endef
26 OPENOBEX_CONF_OPTS += \
27 $(if $(BR2_PACKAGE_OPENOBEX_APPS),--enable-apps) \
28 $(if $(BR2_PACKAGE_OPENOBEX_SYSLOG),--enable-syslog) \
29 $(if $(BR2_PACKAGE_OPENOBEX_DUMP),--enable-dump)
31 ifeq ($(BR2_PACKAGE_OPENOBEX_BLUEZ),y)
32 OPENOBEX_DEPENDENCIES += bluez_utils
33 OPENOBEX_CONF_OPTS += --with-bluez=$(STAGING_DIR)
34 else
35 OPENOBEX_CONF_OPTS += --disable-bluetooth
36 endif
38 ifeq ($(BR2_PACKAGE_OPENOBEX_LIBUSB),y)
39 OPENOBEX_DEPENDENCIES += libusb-compat
40 OPENOBEX_CONF_OPTS += --with-usb=$(STAGING_DIR)
41 else
42 OPENOBEX_CONF_OPTS += --disable-usb
43 endif
45 $(eval $(autotools-package))