1 ################################################################################
5 ################################################################################
8 FAIFA_SITE
= $(call github
,ffainelli
,faifa
,$(FAIFA_VERSION
))
9 FAIFA_INSTALL_STAGING
= YES
10 FAIFA_DEPENDENCIES
= libpcap host-autoconf
11 FAIFA_LICENSE
= BSD-3c
12 FAIFA_LICENSE_FILES
= COPYING
14 FAIFA_MAKE_OPTS
+= GIT_REV
=$(FAIFA_VERSION
)
16 # This package uses autoconf, but not automake, so we need to call
17 # their special autogen.sh script, and have custom target and staging
18 # installation commands.
20 define FAIFA_RUN_AUTOGEN
21 cd
$(@D
) && PATH
=$(BR_PATH
) .
/autogen.sh
23 FAIFA_PRE_CONFIGURE_HOOKS
+= FAIFA_RUN_AUTOGEN
25 define FAIFA_INSTALL_TARGET_CMDS
26 $(TARGET_CONFIGURE_OPTS
) $(MAKE
) -C
$(@D
) \
29 DESTDIR
=$(TARGET_DIR
) \
33 define FAIFA_INSTALL_STAGING_CMDS
34 $(TARGET_CONFIGURE_OPTS
) $(MAKE
) -C
$(@D
) \
37 DESTDIR
=$(STAGING_DIR
) \
41 $(eval
$(autotools-package
))