libglib2: bump to version 2.48.2
[buildroot-gz.git] / package / tor / tor.mk
blob6a622cf0ef6d6eb9adfc09ed6da4e605d1e2fcbf
1 ################################################################################
3 # tor
5 ################################################################################
7 TOR_VERSION = 0.2.7.6
8 TOR_SITE = https://dist.torproject.org
9 TOR_LICENSE = BSD-3c
10 TOR_LICENSE_FILES = LICENSE
11 TOR_DEPENDENCIES = libevent openssl zlib
12 TOR_AUTORECONF = YES
14 TOR_CONF_OPTS = \
15 --disable-gcc-hardening \
16 --disable-unittests \
17 --with-libevent-dir=$(STAGING_DIR)/usr \
18 --with-openssl-dir=$(STAGING_DIR)/usr \
19 --with-zlib-dir=$(STAGING_DIR)/usr
21 ifeq ($(BR2_STATIC_LIBS),y)
22 TOR_CONF_OPTS += \
23 --enable-static-libevent \
24 --enable-static-openssl \
25 --enable-static-tor \
26 --enable-static-zlib
27 endif
29 ifeq ($(BR2_arm)$(BR2_armeb)$(BR2_i386)$(BR2_x86_64)$(BR2_PACKAGE_LIBSECCOMP),yy)
30 TOR_CONF_OPTS += --enable-seccomp
31 TOR_DEPENDENCIES += libseccomp
32 else
33 TOR_CONF_OPTS += --disable-seccomp
34 endif
36 # uses gnu extensions
37 TOR_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
39 $(eval $(autotools-package))