openocd: avoid documentation rebuild to fix build issues
[buildroot-gz.git] / package / libsigrok / libsigrok.mk
blobe4e079d3c8a278775985676260cfaea7786b56af
1 ################################################################################
3 # libsigrok
5 ################################################################################
7 LIBSIGROK_VERSION = 0.4.0
8 LIBSIGROK_SITE = http://sigrok.org/download/source/libsigrok
9 LIBSIGROK_LICENSE = GPLv3+
10 LIBSIGROK_LICENSE_FILES = COPYING
11 LIBSIGROK_INSTALL_STAGING = YES
12 LIBSIGROK_DEPENDENCIES = libglib2 libzip host-pkgconf
13 LIBSIGROK_CONF_OPTS = --disable-glibtest --disable-java --disable-python
15 ifeq ($(BR2_PACKAGE_LIBSERIALPORT),y)
16 LIBSIGROK_CONF_OPTS += --enable-libserialport
17 LIBSIGROK_DEPENDENCIES += libserialport
18 else
19 LIBSIGROK_CONF_OPTS += --disable-libserialport
20 endif
22 ifeq ($(BR2_PACKAGE_LIBFTDI),y)
23 LIBSIGROK_CONF_OPTS += --enable-libftdi
24 LIBSIGROK_DEPENDENCIES += libftdi
25 else
26 LIBSIGROK_CONF_OPTS += --disable-libftdi
27 endif
29 ifeq ($(BR2_PACKAGE_LIBUSB),y)
30 LIBSIGROK_CONF_OPTS += --enable-libusb
31 LIBSIGROK_DEPENDENCIES += libusb
32 else
33 LIBSIGROK_CONF_OPTS += --disable-libusb
34 endif
36 ifeq ($(BR2_PACKAGE_GLIBMM),y)
37 LIBSIGROK_DEPENDENCIES += glibmm
38 endif
40 ifeq ($(BR2_PACKAGE_LIBSIGROKCXX),y)
41 LIBSIGROK_CONF_OPTS += --enable-cxx
42 LIBSIGROK_AUTORECONF_OPTS += -I $(HOST_DIR)/usr/share/autoconf-archive
43 LIBSIGROK_DEPENDENCIES += \
44 host-autoconf-archive \
45 glibmm \
46 host-doxygen \
47 $(if $(BR2_PACKAGE_PYTHON3),host-python3,host-python)
48 else
49 LIBSIGROK_CONF_OPTS += --disable-cxx
50 endif
52 $(eval $(autotools-package))