1 ################################################################################
5 ################################################################################
7 SOCAT_VERSION
= 2.0.0-b9
8 SOCAT_SOURCE
= socat-
$(SOCAT_VERSION
).
tar.bz2
9 SOCAT_SITE
= http
://www.dest-unreach.org
/socat
/download
11 SOCAT_LICENSE_FILES
= COPYING
13 sc_cv_termios_ispeed
=no \
14 sc_cv_sys_crdly_shift
=9 \
15 sc_cv_sys_tabdly_shift
=11 \
16 sc_cv_sys_csize_shift
=4
18 # We need to run autoconf to regenerate the configure script, in order
19 # to ensure that the test checking linux/ext2_fs.h works
20 # properly. However, the package only uses autoconf and not automake,
21 # so we can't use the normal autoreconf logic.
23 SOCAT_DEPENDENCIES
= host-autoconf
25 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
26 SOCAT_DEPENDENCIES
+= openssl
28 SOCAT_CONF_OPTS
+= --disable-openssl
31 ifeq ($(BR2_PACKAGE_READLINE
),y
)
32 SOCAT_DEPENDENCIES
+= readline
34 SOCAT_CONF_OPTS
+= --disable-readline
37 define SOCAT_RUN_AUTOCONF
38 (cd
$(@D
); $(HOST_DIR
)/usr
/bin
/autoconf
)
41 SOCAT_PRE_CONFIGURE_HOOKS
+= SOCAT_RUN_AUTOCONF
43 $(eval
$(autotools-package
))