openocd: avoid documentation rebuild to fix build issues
[buildroot-gz.git] / package / triggerhappy / triggerhappy.mk
blob5a29ca7773d8c1ef8e87a65d23e82782d70efc07
1 ################################################################################
3 # triggerhappy
5 ################################################################################
7 TRIGGERHAPPY_VERSION = 7e5abc69f215678e93a6b999524981c8b40bdcd9
8 TRIGGERHAPPY_SITE = $(call github,wertarbyte,triggerhappy,$(TRIGGERHAPPY_VERSION))
9 TRIGGERHAPPY_LICENSE = GPLv3+
10 TRIGGERHAPPY_LICENSE_FILES = COPYING
12 define TRIGGERHAPPY_BUILD_CMDS
13 $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) thd th-cmd
14 endef
16 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
17 define TRIGGERHAPPY_INSTALL_UDEV_RULE
18 $(INSTALL) -D -m 0644 $(@D)/udev/triggerhappy-udev.rules \
19 $(TARGET_DIR)/lib/udev/rules.d/triggerhappy.rules
20 endef
21 endif
23 define TRIGGERHAPPY_INSTALL_TARGET_CMDS
24 $(INSTALL) -d $(TARGET_DIR)/etc/triggerhappy/triggers.d
25 $(INSTALL) -D -m 0755 $(@D)/thd $(TARGET_DIR)/usr/sbin/thd
26 $(INSTALL) -D -m 0755 $(@D)/th-cmd $(TARGET_DIR)/usr/sbin/th-cmd
27 $(TRIGGERHAPPY_INSTALL_UDEV_RULE)
28 endef
30 define TRIGGERHAPPY_INSTALL_INIT_SYSV
31 $(INSTALL) -m 0755 -D package/triggerhappy/S10triggerhappy \
32 $(TARGET_DIR)/etc/init.d/S10triggerhappy
33 endef
35 define TRIGGERHAPPY_INSTALL_INIT_SYSTEMD
36 $(INSTALL) -D -m 644 package/triggerhappy/triggerhappy.service \
37 $(TARGET_DIR)/usr/lib/systemd/system/triggerhappy.service
38 mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
39 ln -sf ../../../../usr/lib/systemd/system/triggerhappy.service \
40 $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/triggerhappy.service
41 endef
43 $(eval $(generic-package))