1 ################################################################################
5 ################################################################################
7 LIBSTROPHE_VERSION
= 0.8.8
8 LIBSTROPHE_SITE
= $(call github
,strophe
,libstrophe
,$(LIBSTROPHE_VERSION
))
9 LIBSTROPHE_DEPENDENCIES
= openssl host-pkgconf
10 # Doesn't ship configure
11 LIBSTROPHE_AUTORECONF
= YES
12 LIBSTROPHE_LICENSE
= MIT or GPLv3
13 LIBSTROPHE_LICENSE_FILES
= MIT-LICENSE.txt GPL-LICENSE.txt
14 LIBSTROPHE_INSTALL_STAGING
= YES
15 LIBSTROPHE_PATCH
= https
://github.com
/msantos
/libstrophe
/commit
/b08766c8e46956daba010044b00c97f78b598780.patch
17 ifeq ($(BR2_PACKAGE_EXPAT
),y
)
18 # Passing --without-libxml2 doesn't work, due to how AC_ARG_WITH is
19 # used in configure.ac. As long as --with-libxml2 is *not* passed, the
20 # configure script assumes expat should be used.
21 LIBSTROPHE_DEPENDENCIES
+= expat
23 LIBSTROPHE_CONF_OPTS
+= --with-libxml2
24 LIBSTROPHE_DEPENDENCIES
+= libxml2
27 $(eval
$(autotools-package
))