1 ################################################################################
5 ################################################################################
8 AT_SOURCE
= at_
$(AT_VERSION
).orig.
tar.gz
9 AT_SITE
= $(BR2_DEBIAN_MIRROR
)/debian
/pool
/main
/a
/at
10 # missing deps for parsetime.l
13 AT_DEPENDENCIES
= $(if
$(BR2_PACKAGE_FLEX
),flex
) host-bison host-flex
16 --with-jobdir
=/var
/spool
/cron
/atjobs \
17 --with-atspool
=/var
/spool
/cron
/atspool \
18 --with-daemon_username
=root \
19 --with-daemon_groupname
=root \
20 SENDMAIL
=/usr
/sbin
/sendmail
22 define AT_INSTALL_INITSCRIPT
23 $(INSTALL
) -m
0755 -D package
/at
/S99at
$(TARGET_DIR
)/etc
/init.d
/S99at
26 AT_POST_INSTALL_TARGET_HOOKS
+= AT_INSTALL_INITSCRIPT
28 define AT_UNINSTALL_TARGET_CMDS
29 rm -rf
$(addprefix $(TARGET_DIR
),/usr
/lib
/atspool \
38 rm -f
$(addprefix $(TARGET_DIR
)/usr
/man
/man
*/, \
39 at
.1 atq
.1 atrm
.1 batch
.1 at_allow
.5 at_deny
.5 atd
.8 atrun
.8)
42 $(eval
$(autotools-package
))