libnetfilter_cthelper: add patch for uclinux tuple
[buildroot-gz.git] / package / at / at.mk
blob3bed6d5c1941d294a307cc7e3e15f5ebe250f1ba
1 ################################################################################
3 # at
5 ################################################################################
7 AT_VERSION = 3.1.13
8 AT_SOURCE = at_$(AT_VERSION).orig.tar.gz
9 AT_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/a/at
10 # missing deps for parsetime.l
11 AT_MAKE = $(MAKE1)
12 AT_AUTORECONF = YES
13 AT_DEPENDENCIES = $(if $(BR2_PACKAGE_FLEX),flex) host-bison host-flex
15 AT_CONF_OPT = \
16 --with-jobdir=/var/spool/cron/atjobs \
17 --with-atspool=/var/spool/cron/atspool \
18 --with-daemon_username=root \
19 --with-daemon_groupname=root \
20 SENDMAIL=/usr/sbin/sendmail
22 define AT_INSTALL_INITSCRIPT
23 $(INSTALL) -m 0755 -D package/at/S99at $(TARGET_DIR)/etc/init.d/S99at
24 endef
26 AT_POST_INSTALL_TARGET_HOOKS += AT_INSTALL_INITSCRIPT
28 define AT_UNINSTALL_TARGET_CMDS
29 rm -rf $(addprefix $(TARGET_DIR),/usr/lib/atspool \
30 /usr/lib/atjobs \
31 /etc/at.deny \
32 /etc/init.d/S99at \
33 /usr/bin/at \
34 /usr/bin/atrm \
35 /usr/bin/atq \
36 /usr/sbin/atd \
37 /usr/sbin/atrun)
38 rm -f $(addprefix $(TARGET_DIR)/usr/man/man*/, \
39 at.1 atq.1 atrm.1 batch.1 at_allow.5 at_deny.5 atd.8 atrun.8)
40 endef
42 $(eval $(autotools-package))