libnetfilter_cthelper: add patch for uclinux tuple
[buildroot-gz.git] / package / git / git.mk
blobb8a762337f090ae432573b8bf6502fc32d026b51
1 ################################################################################
3 # git
5 ################################################################################
7 GIT_VERSION = 1.8.3
8 GIT_SITE = http://git-core.googlecode.com/files/
9 GIT_LICENSE = GPLv2 LGPLv2.1+
10 GIT_LICENSE_FILES = COPYING LGPL-2.1
11 GIT_DEPENDENCIES = zlib host-gettext
13 ifeq ($(BR2_PACKAGE_OPENSSL),y)
14 GIT_DEPENDENCIES += openssl
15 GIT_CONF_OPT += --with-openssl
16 else
17 GIT_CONF_OPT += --without-openssl
18 endif
20 ifeq ($(BR2_PACKAGE_PERL),y)
21 GIT_DEPENDENCIES += perl
22 GIT_CONF_OPT += --with-libpcre
23 else
24 GIT_CONF_OPT += --without-libpcre
25 endif
27 ifeq ($(BR2_PACKAGE_CURL),y)
28 GIT_DEPENDENCIES += curl
29 GIT_CONF_OPT += --with-curl
30 else
31 GIT_CONF_OPT += --without-curl
32 endif
34 ifeq ($(BR2_PACKAGE_EXPAT),y)
35 GIT_DEPENDENCIES += expat
36 GIT_CONF_OPT += --with-expat
37 else
38 GIT_CONF_OPT += --without-expat
39 endif
41 ifeq ($(BR2_PACKAGE_LIBICONV),y)
42 GIT_DEPENDENCIES += libiconv
43 GIT_CONF_ENV += LIBS=-liconv
44 GIT_CONF_OPT += --with-iconv=/usr/lib
45 else
46 GIT_CONF_OPT += --without-iconv
47 endif
49 ifeq ($(BR2_PACKAGE_TCL),y)
50 GIT_DEPENDENCIES += tcl
51 GIT_CONF_OPT += --with-tcltk
52 else
53 GIT_CONF_OPT += --without-tcltk
54 endif
56 # assume yes for these tests, configure will bail out otherwise
57 # saying error: cannot run test program while cross compiling
58 GIT_CONF_ENV += ac_cv_fread_reads_directories=yes \
59 ac_cv_snprintf_returns_bogus=yes
61 $(eval $(autotools-package))