libnetfilter_cthelper: add patch for uclinux tuple
[buildroot-gz.git] / package / jamvm / jamvm.mk
blob34f1b9f0a4b8900a384d61fb1a229ffc93d2697c
1 ################################################################################
3 # jamvm
5 ################################################################################
7 JAMVM_VERSION = 1.5.4
8 JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMVM_VERSION)
9 JAMVM_DEPENDENCIES = zlib classpath
10 # int inlining seems to crash jamvm, don't build shared version of internal lib
11 JAMVM_CONF_OPT = \
12 --with-classpath-install-dir=/usr \
13 --disable-int-inlining \
14 --disable-shared \
15 --without-pic
17 # jamvm has ARM assembly code that cannot be compiled in Thumb2 mode,
18 # so we must force traditional ARM mode.
19 ifeq ($(BR2_arm),y)
20 JAMVM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -marm"
21 endif
23 $(eval $(autotools-package))