libnetfilter_cthelper: add patch for uclinux tuple
[buildroot-gz.git] / package / sdl_gfx / sdl_gfx.mk
blobc6b94510eec2112bcaef81f7715ce74a186943f3
1 ################################################################################
3 # sdl_gfx
5 ################################################################################
7 SDL_GFX_VERSION = 2.0.23
8 SDL_GFX_SOURCE = SDL_gfx-$(SDL_GFX_VERSION).tar.gz
9 SDL_GFX_SITE = http://www.ferzkopp.net/Software/SDL_gfx-2.0/
10 SDL_GFX_LICENSE = zlib
11 SDL_GFX_LICENSE_FILES = COPYING LICENSE
12 SDL_GFX_INSTALL_STAGING = YES
13 SDL_GFX_DEPENDENCIES = sdl
14 SDL_GFX_CONF_OPT = \
15 --with-sdl-prefix=$(STAGING_DIR)/usr \
16 --disable-sdltest \
17 --enable-static
19 # Even though x86_64 processors support MMX, the MMX-specific assembly
20 # code in sdl_gfx is IA32 specific, and does not build for x86_64.
21 ifeq ($(BR2_i386)$(BR2_X86_CPU_HAS_MMX),yy)
22 SDL_GFX_CONF_OPT += --enable-mmx
23 else
24 SDL_GFX_CONF_OPT += --disable-mmx
25 endif
27 $(eval $(autotools-package))