directfb: do not use inexistant configure options
[buildroot-gz.git] / package / gsl / gsl.mk
blob0ad5377ece0cec842f6895ea9dc1e8d6d483b229
1 ################################################################################
3 # gsl
5 ################################################################################
7 GSL_VERSION = 1.16
8 GSL_SITE = $(BR2_GNU_MIRROR)/gsl
9 GSL_INSTALL_STAGING = YES
10 GSL_LICENSE = GPLv3
11 GSL_LICENSE_FILES = COPYING
12 GSL_CONFIG_SCRIPTS = gsl-config
14 # uClibc pretends to have fenv support as it installs <fenv.h>, but in
15 # practice, it only implements it for i386. Problem reported upstream
16 # at: http://lists.busybox.net/pipermail/uclibc/2012-October/047067.html.
17 # So we tell gsl that fenv related functions are not available in this
18 # case.
19 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
20 ifneq ($(BR2_i386),y)
21 GSL_CONF_ENV = \
22 ac_cv_have_decl_feenableexcept=no \
23 ac_cv_have_decl_fesettrapenable=no
24 endif
25 endif
27 $(eval $(autotools-package))